Symptom
You want to add products to a document from a Product List, but the Product List is not available to be selected.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite: You have created and activated a Product List 123 (123 represents the Product List ID) in your system.
This can happen for different documents such as Opportunities, Sales Quotes, etc. In our example, we will use Sales Quotes.
-
Go to the Sales work center.
- Go to the Sales Quotes view.
- Open the relevant quote ABC (ABC represents the object name).
- Go to the Products facet.
- Click Actions -> Add from Product List.
- Product List 123 is not available to be selected and when you search for it there is no result.
Cause
The Product list and or the products within that list do not match your Opportunity or Sales Quote. Here are some points to check for:
-
The Product list has to be active and valid.
- The Products added to the Product list (Proposed Products) have to be active and valid. This means the Valid To date needs to be in the future. If this field is not visible in the UI, it can be added via personalization or adaptation.
- The Products in the Product List cannot be in status Blocked; if one Product in the List is Blocked, the list won't be available to be added.
- The Product List has to be valid for the account in use. For example, the check Valid for All Accounts could be checked, meaning, the product list is available to any account where the rest of the variables match. If the check is not checked, see if your account is allowed for that product list.
- The Sales Data of the different objects need to match. If you add Sales Areas and Sales Territories, a product list will be determined only if the document has account, sales area, and territory assigned.-> Example: If Product List X (X represents the Product List name) is assigned with Sales Organization A and a Proposed Product is also assigned with same sales Org. for example A and now you are creating an Opportunity with an Account which belongs to same sales Org. for example A, then the Product will be available in Add From List.
Resolution
This is the expected system behavior.
We are constantly thriving to improve our system and hearing your suggestions is the best way forward. Our product managers regularly check the Influence page to hear what changes users would like to see in place and check those for feasibility. Idea requests can also be voted for by other customers.
If you would like to suggest a change to this behavior, please submit your idea at the respective SAP Influence page:
Please note that it is not possible for our Support Team to provide you additional information regarding the availability of this feature in a future release.
Keywords
not found, cannot find, opp, add from product list , KBA , LOD-LE-PRL , Product List , LOD-CRM-OPP , Opportunity Management , Problem