Symptom
When trying to modify the ID of an existing supplier in the system, the Supplier ID field is grayed out and the ID cannot be modified.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Supplier Base work center.
- Select the Suppliers view.
- Show All Suppliers.
- Find ABC (ABC represents the ID of the relevant Supplier).
- Click Edit - General.
The Supplier ID field is grayed out and therefore the ID cannot be modified.
Cause
This is expected system behaviour. Once a new Supplier is saved, the ID cannot be modified.
Resolution
The Supplier created with the wrong ID needs to be marked as obsolete and then a new Supplier has to be created with the correct ID. To mark the Supplier as obsolete, perform the below steps:
- Go to Supplier Base work center.
- Select the Suppliers view.
- Show All Suppliers.
- Find ABC (ABC represents the ID of the relevant Supplier).
- Click Change Status.
- Select Obsolete from the drop-down menu.
- Click Save.
Then, create the Supplier again with the correct ID.
Keywords
Supplier, ID, Wrong, Error, Can't, Cannot, Change, Edit, Modify, Field, Grayed, Out , KBA , SRD-MD-BP-SUP , Suppliers , Problem
SAP Knowledge Base Article - Public