SAP Knowledge Base Article - Public

2613858 - Country Code is missing in the Code List Mapping

Symptom

You have an integration scenario between Cloud for Customer (C4C) and an external system and you notice that certain country codes are missing in Code List Mapping (CountryCode) in C4C.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Business Configuration work center.
  2. Search for the following activity: Code List Mapping for Integration with External Applications and Solutions.
  3. Click on the Maintain Code List Mapping hyperlink.
  4. Under Code List Mapping Definition search for CountryCode.
  5. Observe the Local Codes under Code List Mapping section.

Certain Country codes are missing.

Cause

Not all Country codes are added by default in C4C which are present in external systems.

Resolution

It is possible to add Countries omitted by C4C through business configuration. To achieve this, you need to follow the below steps:

  1. Go to the Business Configuration work center.
  2. Search for activity Countries.
  3. Click on the Edit Countries hyperlink.
  4. Click on the Add Row button and add the missing country. (E.g.: Country - XK, Description - Kosovo)
  5. Save and close the window.
  6. Search for activity Code List Mapping for Integration with External Applications and Solutions.
  7. Click on the Maintain Code List Mapping hyperlink.
  8. Under Code List Mapping Definition section select CountryCode.
  9. Click on the Add Row button under Code List Mapping section and add the missing country code.

Keywords

missing country code, code list mapping, CountryCode, C4C, Cloud for Customer, Countr, Code List, Mapping, Code, List , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-INT-CRM , Integration of C4C with CRM , How To

Product

SAP Cloud for Customer add-ins all versions