SAP Knowledge Base Article - Public

2614022 - "Unable to connect to SAP SuccessFactors. Check the connection details and user credentials then try again." error in SAP Analytics Cloud

Symptom

  • The following error appears when trying to connect to SAP SuccessFactors (SF) using SAP Analytics Cloud (SAC):
    "Unable to connect to SAP SuccessFactors. Check the connection details and user credentials then try again."
  • The following error appears in the browser Developer Tools Network tab:
    "{"error":{"code":"ERROR_AUTHENTICATION_FAILURE","rawError":"Failed to get access token with message: Unauthorized {\"errorHttpCode\":\"401\",\"errorMessage\":\"Unable to authenticate the client (Login failed - invalid ip)\"}","params":["Unauthorized {\"errorHttpCode\":\"401\",\"errorMessage\":\"Unable to authenticate the client (Login failed - invalid ip)\"}"]}}"

Environment

  • SAP Analytics Cloud
  • SAP SuccessFactors

Reproducing the Issue

  1. Follow article 2339542 - How to connect to SAP SuccessFactors from SAP Analytics Cloud.
  2. Notice the error after clicking on "Create".

Cause

The problem is caused by IP restriction management, which has been set up and that the allow list does not contain the SAP Analytics Cloud datacenter IP address range.

Resolution

  1. Go to Admin Tools > Password & Login Policy Settings in SuccessFactors.
  2. Select "Set API login exceptions..."  and click on the Add button.
  3. Add the IP range belongs to SAP Analytics Cloud tenant datacenter, as per: SAP Cloud Platform online help.
  4. Create the connection in SAP Analytics Cloud.

More information in article: 2089414 - System: How to restrict access to SuccessFactors by IP address - IP Restriction Management

See Also

Your feedback is important to help us improve our knowledge base.

Keywords

Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics, SF, SAPSF, IP, ranage, Admin Center, Password & Login Policy Settings, whitelist, white list , KBA , LOD-ANA-AQU , Import Data Connections (Acquiring Data) , Problem

Product

SAP Analytics Cloud 1.0