SAP Knowledge Base Article - Public

2614187 - Unable to initiate background check. Error occurred while executing integration center process - Recruiting Management

Symptom

  • When initiating the background check for a candidate, the following error is received:
    • 'Unable to initiate background check. Error occured while executing integration center process.'
  • Why is this error occurring and how can this be fixed to proceed with initiating the background check?

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Recruiting > Select a candidate from 'Background Check' status
  2. Take Action > Initiate Background Check
  3. Error will occur:

'Unable to initiate background check. Error occured while executing integration center process.'

Cause

  • Here is one cause of this error according to the logs from Splunk:
    • Exceptionoccurredwhileinitiatingbackgroundcheckforapplicant35202com.successfactors.sca.ServiceApplicationException:com.successfactors.integrationframework.service.rt.IntegrationFrwkExecutorException:ODataAPIApplicationExportpermissioninAdminCenterisnotenabled
  • Another cause is when the OData API Candidate Export permission in Admin Center is not enabled.

Resolution

As advised from Splunk logs, 'OData API Application Export' or 'OData API Candidate Export' permission is not enabled.

Please add the following permissions to affected user from Recruiting Permissions:

  • OData API Application Export
  • OData API Application Create
  • OData API Application Update
  • OData API Candidate Export

If the issue still persists after assigning the permissions, please run an ODATA API Metadata Refresh.

See Also

2251702 - OData API Integration with Recruiting Management

Keywords

Background, Check, Initiate, Error, Unable , KBA , LOD-SF-RCM-BCI , Background Check , Problem

Product

SAP SuccessFactors Recruiting all versions