Symptom
When you change the billing plan of a contract on item level, the billing plan is not changed on the contract overview.
Environment
SAP Hybris Cloud for Customer 1802/ 02 and higher versions.
Reproducing the Issue
-
Go to the Contracts work center.
- Select the Contracts view.
- Open Contract ID XYZ (XYZ represents the contract ID).
- Go to the Items section.
- Select Item 123 (123 represents the item line).
- Go to the Billing Plan tab.
- Change the Billing Interval, for example, to Monthly.
- Now go back to the Overview section.
- See that the Billing Interval has not been changed.
Cause
The Billing Plan details are not passed from item level to overview level. Only from overview level to item level.
Resolution
This is the system expected behavior.
-
When you maintain the Billing Plan on the Overview, all Items will be refreshed to have the same Billing Plan.
-
If you change one Item's Billing Plan, it will be updated but the Overview Billing Plan and other Items' Billing Plans will not be updated.
-
If there is a manual change on the Billing Plan at Item level, any further changes on the Billing Plan at Overview level will not take place.
If you need this changed urgently you may contact your implementation manager.
You can find more details about the services offered by Cloud Service Center on https://www.sap.com/services/application-development.html . You can contact Cloud Service Center as follows:
- If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder
- If you are a customer: please use the little blue box “Contact Us” shown on the very right hand side of https://www.sap.com/services/application-development.html, choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page
Keywords
Billing Plan ; Item ; Contract ; Overview ; Header ; , KBA , LOD-LE-COP , Contract Processing , How To