Symptom
Unable to configure custom social media message import run on Cloud for Social Engagement.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
- Go to Administrator work center.
- Select the Service and Social Settings view.
- Click on the hyperlink Social Media Message Import Runs under Social Media.
- Click New button.
- Select Creation Run.
- Click Add Row.
- Click Value Selection box.
- You can not find Custom Owned Social Media Channel created.
Cause
This is expected system behavior.
Resolution
Cloud for Social Engagement supports batch extraction only for channels supported by the solution Facebook, Twitter and Social Media Analytics. For custom channels, Cloud for Social Engagement cannot extract messages. You will have to write your own extractor to search and find messages from the external source, and post them into Cloud for Social Engagement using the webservice APIs. This is explained in the document Facebook Integration FAQ in the SAP Help Portal.
Keywords
Social Media Message Import Run ; Social Engamennt , KBA , LOD-CRM-SC-SM , Social Media , How To