Symptom
- Customer can see many users with missing FirstName or LastName or Email under Security => Users .
- Customer do not want to include such users who miss this data in User Sync file
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Onboarding 1.0
Reproducing the Issue
- In User sync file from BizX , many users/candidates have missing FirstName or LastName or Email
- when Onboarding process the file, same missing data can be noticed in Security => Users
Cause
Configuration needs to be corrected.
Resolution
For Live Customers and/or Implementation Partners
- Super Admin access is needed. (For customers with no Implementation Partnes, please raise support ticket.)
- Navigate to Super admin => Accounts => Account Options
- Search for feature name :
HRDataService.SyncUser.CheckExistenceOfFirstName
HRDataService.SyncUser.CheckExistenceOfLastName
HRDataService.SyncUser.CheckExistenceOfEmail
By default value will be False, change this to True to ensure above fields are validated while adding record in Security >> Users.
NOTE: Setting these Account Option keys to 'True' means this will not sync the users to onboarding without any emails, first name, or last name.
See Also
NA
Keywords
FirstName missing , LastName missing , Email missing , ExistenceOfEmail , Security users, ONB, Onboarding 1.0, ONB1.0, OBD , KBA , LOD-SF-OBD-REP , Reporting & Analytics, Data Imports & Exports , LOD-SF-OBD-ADM , Admin Tools, Settings, Permissions , Problem