Symptom
You create a service ticket in Cloud for Customer (C4C) with a contact which is not assigned to the account. You release the ticket to your ERP system, the message leaves C4C successfully, however, it failes in ERP with the following error:
'Error during processing of BAPI methods'
'Partner maintenance: Partner number missing for an entry with role'
Environment
SAP Hybris Cloud for Customer
SAP ERP
Reproducing the Issue
Pre-requisites: you have a working service ticket follow-up integration scenario between C4C and ERP.
-
Go to the Service work center in C4C.
- Go to the Tickets view and open a ticket.
- Under the Overview tab add a customer and also add a contact which is not assigned to the account.
- Save your changes and click on the Release to ERP button.
- Go to the Administrator work center.
- Under the General Settings view open Web Service Message Monitoring.
- Observe the outgoing message for the above ticket: the message is successful, however, the <RecipientPartyID> tags are missing.
- Open your ERP system and observe the incoming Idoc in transaction WE02 (or WE05).
Result: the idoc is failing in ERP with the following errors:
'Error during processing of BAPI methods'
'Partner maintenance: Partner number missing for an entry with role'
Cause
Adding contact in a service ticket which is not assigned to the account is not a supported scenario for integration. The ERP contact is mapped to the C4C contact relationship. Therefore, if there is no relationship, it is not possible to determine the ERP contact ID.
As the contact is not assigned to the account, valid ID mapping entry is not getting determined and <RecipientPartyID> tag is missing in the payload.
Resolution
You need to select a contact in the service ticket which is assigned to the account to correct this error.
Keywords
service ticket, contact, BAPI methods, Partner Maintenance, Partner number missing, CO_APCRM_SRQ_SUCC_CREATION_OUT , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To