SAP Knowledge Base Article - Public

2615360 - DRTM Master Data Purge for Inactive Users

Symptom

  • SuccessFactors new data purge solution for Data Protection and Privacy now provides a master data purge of inactive users. Master Data Purge will purge module and audit data permanently, the purge obsolete data and inactive users from Successfactors which removes them from the system
  • Data Retention Time Management soft purges the user which would keep the purged user's record in the USERS_SYSINFO table. If you wish to remove the user completely from the system you must also permanently purge the user.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors HCM Suite

Cause

Prerequisites

  • To use the master data purge, it is necessary to enable the data retention time management (DRTM) solution and the DRTM Master Data purge object
  • To use data retention time management (DRTM) functionality in the Data Retention Management tool, you need to have the following features enabled
    1. Data Retention Management (DRM 2.0) enabled 
    2. Metadata Framework (MDF) enabled  
    3. Role-based Permissions (RBP) enabled 

Further details? Please go through our reference help portal →  🔗 Prerequisites for Data Retention Time Management | SAP Help Portal & Purging Inactive Users with DRTM | SAP Help Portal

Resolution

  • The master data purge process is designed to ensure that data across the HCM Suite is purged first, before the user account, to avoid orphaned data
  • You can configure a different retention time for master data in each country/region, calculated from the employee's termination date

Setting Up Data Retention Time Management DRTM Master Data Purge Object

  1. Add the required DRTM Master Data purge object to your instance, using theUpgrade Center

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  1. Grant users permission to configure retention times using the Metadata Framework (MDF) see below:
  • MetaData Framework (MDF)  Category -- Select All to configure Retention Time

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  • Data Retention Management Category: DRTM Master Data MDF Permission with create, insert, correct, delete and import/export

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  1. Create and Approve Purge Request Permission
  • Manage Data Purge Category: Create and Approve DRTM Data Purge Request

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  1. Manage Users Category – Manage Users

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  1. Enable retention time configuration for each country where it is required, using the MDF Country object.
  • Go to Admin Center > Manage Data > DRTM Master Data  > USER > Take Action > Make Correction > Add Country, timeUnit, inactivePeriod

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Note: If no country found in List, go to Manage Data > Country > Select 1 country and set Data Retention Enabled =Yes

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  1. Ensure the fields "country" and "exit date" are set in User Data File. The DRTM Master Data purge should only deal with inactive user & matched country value & user exit Data out of retention time configuration.
    1. Go to Manage Business Configuration
    2. Expand Employee Profile
    3. Expand Standard
    4. Open Country field
    5. Enable it
    1. Still in Manage Business Configuration
    2. Expand Employee Profile
    3. Expand View Template
    4. Open sysUserDirectorySetting
    5. Click on Take action > Make Correction
    6. Open the Details link for both sysAllUserDirectorySetting and sysVisibleUserDirectorySetting
      Results: You will be able to add the standard element Country that we enabled before

Please perform the same steps below for the "exit date" field.

Once completing above steps, navigate to Master Data Purge > Create Purge Request

  1. Go to Admin Center > Data Retention Management > Create New Purge Request > Under "Select a purge request type", choose "DRTM Master Data Purge".
           Note - If you do not see any purge request types in the dropdown that begin with the abbreviation "DRTM", you may not have Create DRTM Data Purge Request permission.
                     If you have this permission but do not see DRTM Master Data Purge, you may still need to add it to your instance using the Upgrade Center.
  2. Use subject criteria to define the users whose data you want to purge:
  3. Choose from the available options.
    • Select one user. Use this option to purge data for an individual user.
    • Upload a user list (by User ID or Assignment ID). Use this option to purge data for multiple users, based on your own criteria. Use the downloadable CSV example as a template.
      Note Ensure that the import file only has one column and that the column header matches the unique identifier field you use. By default, the column header is Assignment ID. You can use Assignment ID or User Id.
    • Ignore data retention time configuration for this purge request. When you purge data for an individual or a list of inactive users, use this option to ignore data retention times and purge data immediately. This option enables you to quickly purge data that no longer has any business need, if you are required to do so.
    • Select countries. Use this option to purge data for multiple users in one or more countries. This option enables you to set up a recurring or reusable purge request for specified countries, according to your data retention policy.
    • Select legal entities. Use this option to purge data for multiple users in one or more legal entities in Employee Central. This option enables you to set up a recurring or reusable purge request for specified legal entities, according to your data retention policy
  4. If needed, specify users by country/region or by legal entity. Select one or more using the dropdown menu.
            Note - You can only select countries or regions that have been set up to use data retention time management (DRTM). If you don't see the one you are looking for, contact your administrator to have it enabled.
  5. If desired, deselect User belongs to an incomplete compensation or variable pay form to include inactive users in this purge, whether or not they belong to an incomplete compensation or variable pay form.
  6. Add one or more approvers. Use the Add approvers search box to add the first approver. To add another, select Add another approver.
  7. Launch immediately or Schedule
  8. Go to Admin Center > Maintenance Monitor > Check Request Awaiting Approval Tab
  9. The request created will displayed
  10. Approve/Decline Request as required

Notes:

  • Ensure that country/region records have values maintained  that are supported by the DRTM data purge function. [Reference: Country/Region Names Required for Data Purge | SAP Help Portal ]
  • With 1H 2024 Production Release, The option Ignore data retention time configuration for this purge request for DRTM Master Data purge requests will enable you to purge data immediately with fewer restrictions: Now, with the option selected, the DRTM Master Data Purge can skip the validation of the users' country/region record and termination date record. For example, although a user's country/region record doesn't match the country names defined in the MDF object for country/region, the user's data can still be purged immediately.
  • "Exclude users that meet the following criteria" options are not the exact same as it was under "Purge inactive users" purge. If any new criteria is needed to be added in this section, it will need to be submitted as an enhancement request as per KBA  2090228 - How to Submit Ideas for SAP SuccessFactors Products.

Further details? Please refer to Enhancement to DRTM Master Data Purge | SAP Help Portal.

 

FAQ - Additional Information

Q) Where can I get information on this from the Guide?

A) Guide: Implementing and Managing Data Protection and Privacy

Chapter: DRTM Master Data Purge | SAP Help Portal

Q) Is it possible to re-activate purged users which have been soft purged using the legacy purge inactive user Data Retention Management Purge or Data Retention Time Management Purge?

A)  Yes, A Soft purge is when the user is still existing at the Database level. View: 2392094 - Re-activate a Purged User Via employee Import Feature

Q) Is it possible to re-use the username from purged users which have been soft purged using the legacy purge inactive user Data Retention Management Purge or Data Retention Time Management Purge?

A) Yes, on soft purge process the user's username is data is anonymized in the database level leaving the username record available to be used in a new user.

Q) Customer are getting this error "'USER' is an operator for open or pre-approved requisitions " while purging the request.

A) Customer may need to move the requisitions to another user or close these requisition. For more details on moving or closing the requistions, we need to get checked with RCM team (LOD-SF-RCM)

See Also

  • 3382120 - How the cutoff dates work on DRTM of Employment Information - Employee Central
  • 2657326 - Data Retention Time Management: Person and Employment Purge Object FAQ
  • 2661609 - Required Field purgeGroup or Purge Object Group Field Are Not Editable in Data Retention Time Management (DRTM)
  • 2608124 - Cannot Select Country While Creating DRTM - Employee Profile in Manage Data
  • 2674762 - DRTM Purge Configuration - EC Disabled Company - Configuration and Troubleshooting 
  • 2545988 - How to Purge/Delete users in SuccessFactors 
  • 3058601 - How To Check Soft or Permanent Purge User

Keywords

SF, success factors, DRTM, PLT, platform, Biz X, bizx, object, MDF, Metadata Framework, DRM, purgeGroup, Purge Object Group, Upgrade Center, purge, DRTM   , KBA , LOD-SF-PLT-DRM , Data Retention Management , LOD-SF-EC , Employee Central , LOD-SF-PLT , Platform Foundational Capabilities , LOD-SF-EC-ADM , Admin Tools (EC Core only) , Problem

Product

SAP SuccessFactors HCM Suite all versions