Symptom
SuccessFactors HCM suite stores a wide range of user's information. Generally speaking, historical data should not be stored any longer than is required. Once the required retention time has passed, data should be purged. A data purge is a means of permanently removing data from storage.
It might also be necessary to purge user data from the system because it no longer serves any business purpose.
To meet this requirement, SAP SuccessFactors provides the ability to purge different types of data across the HCM suite, on a recurring schedule or not and based on configurable retention times.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors HCM Suite
Cause
Prerequisites
- To use the master data purge, it is necessary to enable the data retention time management (DRTM) solution and the DRTM Master Data purge object
- To use data retention time management (DRTM) functionality in the Data Retention Management tool, the following features have to be enabled:
-
- Data Retention Management (DRM 2.0)
- Metadata Framework (MDF)
- Role-based Permissions (RBP)
Help Portal documentation for further details:
Resolution
- The master data purge process is designed to ensure that data across the HCM Suite is purged first, before the user account, to avoid orphaned data.
- A different retention time for master data can be configured for each country/region. It is calculated from the employee's termination date.
- Data Retention Time Management soft purges the user which will keep the user's record in the USERS_SYSINFO table. To remove the user completely from the system, permanent purge has to be also performed.
Setting Up Data Retention Time Management DRTM Master Data Purge Object
1. Add the required DRTM Master Data purge object to your instance, using theUpgrade Center
2. Grant users permission to configure retention times using the Metadata Framework (MDF) see below:
- MetaData Framework (MDF) Category -- Select All to configure Retention Time
- Data Retention Management Category: DRTM Master Data MDF Permission with create, insert, correct, delete and import/export
2. Create and Approve Purge Request Permission
- Manage Data Purge Category: Create and Approve DRTM Data Purge Request
- Manage Users Category – Manage Users
3. Enable retention time configuration for each country where it is required, using the MDF Country object.
- Go to Admin Center > Manage Data > DRTM Master Data > USER > Take Action > Make Correction > Add Country, timeUnit, inactivePeriod
Note: If no country was found in the List, go to Manage Data > Country > Select a country and set Data Retention Enabled =Yes
Ensure the fields "country" and "exit date" are set in User Data File. The DRTM Master Data purge should only deal with inactive user & matched country value & user exit Data out of retention time configuration.
How to Enable the Country and Exit Date Fields
- Go to Admin Center > Manage Business Configuration > Employee Profile > Standard.
- Open the Country/Exit Date field and set it to Enabled.
- Add the field to user directory settings:
- Navigate to Employee Profile > View Template > sysUserDirectorySetting > Take Action > Make Correction.
- Open Details for sysAllUserDirectorySetting and sysVisibleUserDirectorySetting.
- Add the Country/Exit Daye field so it is visible in the system.
- Results: You will be able to add the standard element Country that we enabled before
Once the steps above are complete, proceed on submitting the Purge Request:
How to Create a Purge Request
- Go to Admin Center > Data Retention Management > Create New Purge Request.
- Under Select a purge request type, choose DRTM Master Data Purge.
NOTE:
- If no purge request types starting with DRTM appear in the dropdown, the Create DRTM Data Purge Request permission might be missing.
- If the permission in properly set and DRTM Master Data Purge is still not available, it has to be add to the instance via the Upgrade Center.
- Use subject criteria to define the users whose data you want to purge:
- Choose from the available options below:
-
- Select one user - to purge data for an individual user.
- Upload a list of inactive users only (by User ID or Assignment ID) - to purge data for multiple users. The downloadable CSV example can ben used as a template.
- NOTE: The import file must have only one column, and that the column header matches the unique identifier you are using. By default, the header is Assignment ID, but you can use either Assignment ID or User ID. Make sure the header is updated to match your chosen identifier. Maximum number of users recommended for single purge is 10,000 users. See Help Portal - Best Practice for Purging Data Targeting Large Number of Users
- NOTE: The import file must have only one column, and that the column header matches the unique identifier you are using. By default, the header is Assignment ID, but you can use either Assignment ID or User ID. Make sure the header is updated to match your chosen identifier. Maximum number of users recommended for single purge is 10,000 users. See Help Portal - Best Practice for Purging Data Targeting Large Number of Users
- Ignore data retention time configuration for this purge request - when purging data for an individual or a list of inactive users, use this option to ignore data retention times and purge data immediately with fewer restrictions: the DRTM Master Data Purge skips user's validations as country/region record and termination date record. For example: although a user's country/region record doesn't match the country names defined in the MDF object for country/region, the user's data can still be purged immediately.
- NOTE: When the "Upload a list" option is chosen, the Ignore checkbox only becomes available once the "Upload" button is clicked.
- Select countries/regions - this option can be used to purge data for multiple users in one or more countries. This option enables you to set up a recurring or reusable purge request for specified countries, according to your data retention policy.
- Select legal entities - to purge data for multiple users in one or more legal entities in Employee Central. This option enables you to set up a recurring or reusable purge request for specified legal entities, according to your data retention policy
- NOTES:
- If needed, specify users by country/region or by legal entity. Select one or more using the dropdown menu.
- You can only select countries or regions that have been set up to use data retention time management (DRTM). See more in Help Portal - Enabling Data Retention Time Management for Each Country or Region
- NOTES:
6. If desired, deselect User belongs to an incomplete compensation or variable pay form to include inactive users in this purge, whether or not they belong to an incomplete compensation or variable pay form.
7. Add one or more approvers. Use the Add approvers search box to add the first approver. To add another, select Add another approver.
8. Launch immediately or Schedule
9. Go to Admin Center > Purge Request Monitor > Check "Requests Pending Final Approval" Tab
10. The request created will displayed
11. Request can be Approved/Declined
NOTES:
- Ensure that country/region records have values maintained that are supported by the DRTM data purge function. See Help Portal - Country/Region Names Required for Data Purge
- "Exclude users that meet the following criteria" options are not the exact same as it was under "Purge inactive users" purge. If any new criteria is needed to be added in this section, it will need to be submitted as an enhancement request as per KBA 2090228 - How to Submit Ideas for SAP SuccessFactors Products.
Frequently Asked Questions (FAQ) & Additional Information
Q) Where can I get information on this from the Guide?
A) Guide: Implementing and Managing Data Protection and Privacy
Chapter: DRTM Master Data Purge
Q) Is it possible to re-activate purged users which have been soft purged using the legacy purge inactive user Data Retention Management Purge or Data Retention Time Management Purge?
A) Yes, A Soft purge is when the user is still existing at the Database level. View: 2392094 - Re-activate a Purged User Via employee Import Feature
Q) Is it possible to re-use the username from purged users which have been soft purged using the legacy purge inactive user Data Retention Management Purge or Data Retention Time Management Purge?
A) Yes, on soft purge process the user's username is data is anonymized in the database level leaving the username record available to be used in a new user.
Q) Customer are getting this error "'USER' is an operator for open or pre-approved requisitions " while purging the request.
A) Customer may need to move the requisitions to another user or close these requisition. For more details on moving or closing the requisitions, we need to get checked with RCM team (LOD-SF-RCM)
Q) Does the SuccessFactors DRTM Master Data Purge for employees delete the entire record for a purged user?
A) The DRTM Master Data Purge for employees deletes the entire user record along with all associated data across the SuccessFactors HCM suite.
Q) Is the DRTM Master Data Purge applicable to all SuccessFactors modules?
A) The DRTM Master Data Purge triggers module-specific purge functions to remove data belonging to each module. Therefore, it is applicable to all SuccessFactors modules.
See Also
- KBA 3382120 - How the cutoff dates work on DRTM of Employment Information - Employee Central
- KBA 2657326 - Data Retention Time Management: Person and Employment Purge Object FAQ
- KBA 2661609 - Required Field purgeGroup or Purge Object Group Field Are Not Editable in Data Retention Time Management (DRTM)
- KBA 2608124 - Cannot Select Country While Creating DRTM - Employee Profile in Manage Data
- KBA 2674762 - DRTM Purge errors related to user's Country
- KBA 2545988 - How to Purge/Delete users in SuccessFactors
- KBA 3058601 - How To Check Soft- Purged and Hard (Permanent) Purged users
- KBA 3490948 - DRTM Master Data Purge job failed with the error "This user is still within retention time period"
- KBA 2179378 - Purge Request fails automatically with "Reviewing..." status
Keywords
SF, success factors, DRTM, PLT, platform, Biz X, bizx, object, MDF, Metadata Framework, DRM, purgeGroup, Purge Object Group, Upgrade Center, purge, DRTM, ignore data retention time , KBA , LOD-SF-PLT-DRM , Data Retention Management , LOD-SF-EC , Employee Central , LOD-SF-PLT , Platform Foundational Capabilities , LOD-SF-EC-ADM , Admin Tools (EC Core only) , How To
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