Symptom
You are able to save a newly created opportunity without all mandatory fields filled out.
Environment
- SAP Hybris Cloud for Customer in Responsive User Interface (RUI)
- All supported Browsers
Reproducing the Issue
- Go to the Sales work center.
- Go to the Opportunities view.
- Create a new opportunity by clicking on the '+' button.
- Fill out all details except for one mandatory field.
- Click on the top right corner on the three little dots.
- Click Close All.
- Click on Yes in the popup window.
- The opportunity gets saved even though not all mandatory fields were filled out.
Cause
The Check event, which checks the mandatory fields for content is bypassed.
Resolution
This is a known issue, it is on the development team's roadmap and will be fixed with an upcoming release.
Keywords
madatory , field , save , opportunity , KBA , LOD-CRM-PM-PF , C4C Product Management - Platform , How To
Product
SAP Cloud for Customer 1211 ; SAP Cloud for Customer 1302 ; SAP Cloud for Customer 1305 ; SAP Cloud for Customer 1308 ; SAP Cloud for Customer 1311 ; SAP Cloud for Customer 1402 ; SAP Cloud for Customer 1405 ; SAP Cloud for Customer 1408 ; SAP Cloud for Customer 1411 ; SAP Cloud for Customer 1502 ; SAP Cloud for Customer 1505 ; SAP Cloud for Customer 1508 ; SAP Cloud for Customer 1511 ; SAP Cloud for Customer 1602 ; SAP Cloud for Customer add-ins 1802 ; SAP Cloud for Customer add-ins 1805 ; SAP Cloud for Sales 3.0 ; SAP Hybris Cloud for Customer add-ins 1605 ; SAP Hybris Cloud for Customer add-ins 1608 ; SAP Hybris Cloud for Customer add-ins 1611 ; SAP Hybris Cloud for Customer add-ins 1702 ; SAP Hybris Cloud for Customer add-ins 1705 ; SAP Hybris Cloud for Customer add-ins 1708 ; SAP Hybris Cloud for Customer add-ins 1711 ; SAP Sales OnDemand 1.0 ; SAP Sales OnDemand 2.0 ; SAP Sales OnDemand 4.0