Symptom
Extension field is read only during inbound call in Live Activity Center.
Environment
SAP Service Cloud
Reproducing the Issue
Pre-requisites:
You have already created extension field ABC for Live Activity Center (ABC represents the name of the extension field).
- Log into the Fiori client.
- Go to the Service work center.
- Select the Live Activity Center view.
- Simulate an inbound call.
- Accept the call.
In the Call information section you can see that extension field ABC is read only.
Cause
Extension fields are not editable in the Fiori UI because the Live Activity Center UI floorplan is an OWL, and in OWLs extension fields are not editable.
Resolution
This is as framework current limitation. The functionality is planned to be enhanced and at this point in time, we are not in a position to provide more accurate information on date and/or timelines for this.
As a current workaround, an Embedded Component can be created, with the extension fields inside the ECs. This way the extension fields are editable.
1. Create a new Embedded Component in PDI.
2. Choose Embedded Component.
3. Open the Embedded component in UI Designer for modelling.
4. Configure the embedded component UI.
5. Configure the inport to get the data from Live activity configuration.
6. Open Live Activity Screen UI under /BYD_COD/ServiceOnDemand/CTI/LiveActivity/LiveActivityInteraction_OWL.OWL.uicomponent.
7. Add the Embedded Component and Bind to the outport.
8. Bind the URL Parameters to Pass value from Floor plan to Embedded Component
Use the Outport that you want to add.
The naming convention of the PDI Ourport is "PublicOutport*". Right now we support these three Outport for PDI implementaion:
PublicOutportOnClickSearchResult(available from 1805 only), PublicOutportDataIntegration, PublicOutportWithCADData.
Keywords
Extension Field, Read Only, Live Activity Center. , KBA , extension field , read only , live activity center. , LOD-CRM-LA , Live Activity , Problem