Symptom
You try to add a new contact to a partner and receive the error message ‘Employee inconsistent; employee ID in Identification missing’
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
- Go to the Partners work center
- Go to Partners view.
- Open a partner
- Go to the Contacts facet.
- Click on New and fill in the required details.
- Click on Save.
- You receive the error message: 'Employee inconsistent; employee ID in Identification missing’
Cause
You need to adjust the activity 'Number Ranges for Employees and Service Agents' to automatic.
Resolution
- Go to the Business Configuration Work Center.
- Go to the Implementation Projects view.
- Click on Open Activity List.
- Search and open activity 'Number Ranges for Employees and Service Agents'.
- Change the type to automatic.
- Save the changes.
Observation: The use of manual number range is intended for the first data entry or migration process. After that, please maintain the number range (begin number / end number) and allow the system to automatically increment the numbering for employees / service agents.
Keywords
Partner, Contact, Number Range for Employees and Service Agents , KBA , partner , contact , employee , number range , LOD-CRM-PRN , Partner , How To