SAP Knowledge Base Article - Public

2615740 - Even Though you Successfully Deleted a Contact, Some Related Data can Still be Seen in the Respective Feed Entries

Symptom

Feed entries about deleted/anonymized Contacts still display their related data.

Environment

SAP CLOUD FOR CUSTOMER

Reproducing the Issue

  1. Go the Data Protection and Privacy workcenter.
  2. Go to the Personal Data Removal view.
  3. Select All Contacts.
  4. Find and select concerned Contact ABC (ABC represents the Contact you want to delete).
  5. Click Remove data.
  6. Click Delete.
  7. Go to the Feed workcenter.
  8. Go to the Feed view.

Results: You can find Feed entries with the name and first name of the deleted Contact.

Cause

From the GDPR (General Data Protection Regulation) angle of the Feeds, anonymization is not technically feasible.

Resolution

Soft Deletion And Hard Deletion of Feeds are to be made available with the 1805 upgrade, for the key User to set in the Common Tasks of the Administrator workcenter.

Keywords

Feed data, Feed Entry, Data Privacy Management, Data Privacy and Protection, GDPR, Feed Duration Settings, Feed Duration, Common tasks, Deleted Contact, Anonymized, Soft Deletion, Hard Deletion. , KBA , SRD-CC-FED , Feeds , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions