Symptom
You complete a Service Process via Service Order and create a Service Confirmation as well as an Invoice, but the Service Order does not complete, because one of the Line Item has the Invoice Status Not Started.
Environment
SAP Business ByDesign
Reproducing the Issue
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Create Service Order ABC (ABC represents the ID of the Service Order).
- Follow Up on the Service Order with a Service Confirmation.
- Change in the Follow Up Service Confirmation the Product ID for one Line Item.
- Submit the Service Confirmation with Order Completion.
- Invoice the generated Service Confirmation Invoice Request.
- Navigate back to Service Order ABC.
- Select Tab Spare Parts and Services.
You can see that Line Item 10 is still in Status In Process with Invoice Status Not Started.
When you create a new Service Confirmation, you cannot reference Line Item 10 from Service Order ABC.
Cause
-
By changing the Product ID in the Service Confirmation, but keeping the Service Order Reference, the Line item is blocked in Service Order ABC.
- However when you create the Invoice from the Service Confirmation, the Invoice cannot update the Service Order ABC, because the entered Product ID is not available in the Service Order.
- Thus the Invoicing Status remains Not Started.
Resolution
In order to resolve this issue and complete the Service Order, you will need to change or cancel the Follow Up Service Confirmation.
- To cancel or change the service confirmation follow KBA 2585089.
- When creating a new Service Confirmation, you need to use the same Product ID in the Service Confirmation as in the Service Order.
See Also
KBA 2585089 - How To Correct a Service Confirmation When The Status is Not Relevant, click here.
Keywords
Service Order, Service Confirmation, Invoice Status, Complete, Serviceauftrag, Servicerückmeldung, Rechnungsstatus, Abschließen , KBA , AP-SVO-SO , Service Order , Problem