Symptom
Why is the custom tokens field labels blank / empty display when adding a custom token to an email template?
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Within the Recruiting Management system, go to any page that allows you to edit an email body;
- By the top of the email body box, there are a few tools buttons, click the one called "Insert job requisition field" on the right side. This will open all your existing tokens for selection;
- (Issue) - See that not all custom tokens have their label available
Cause
It was identified that this issue is caused when the field associated with the custom token is not defined in the required templates.
Resolution
Considering what was mentioned in the "Cause" section, it is now required to define all the fields that were used in the creation of a custom token.
NOTE : These field ids are case sensitive.
See the below example:
- The custom field "cand_desired_salary" was created and properly defined in the job requisition application template;
- This same field was associented to the custom token [[JOB_APPLICATION_CUSTOM6]];
- It will then be available to be used as a custom token (following the same steps provided in the "Reproducing the issue" section)
The issue will occur when the client does not follow the first step mentioned above. So, to avoid this issue, make sure to have all the necessary fields defined in the required templates.
Keywords
label, blank, email, template, displaying , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , How To