Symptom
You set up some fields to be mandatory in an appointment.
When you create an appointment from C4C, the system won’t let you save the appointment until these mandatory fields are filled in.
However, if the appointment is created from Outlook, the same fields will not be mandatory and outlook will be able to save these appointments without filling in the same fields.
Environment
- SAP Add-In for Microsoft Outlook
- SAP Hybris Cloud for Customer
Reproducing the Issue
- Go to the activities work centre.
- Go to the appointments view.
- Click on New.
Result: You can see field ABC which is mandatory. In this example, we use the field Account. -
Log in in the Outlook add in.
-
Go to the calendar view.
-
Click New appointment.
-
Click Add appointment.
-
Click Submit.
Result: You can save the appointment without entering an account. Consequently, this appointment will appear in the system without the compulsory information.
Cause
This is the current system’s behaviour. Fields which are made mandatory in the system won't become mandatory in Outlook.
One view having mandatory fields does not automatically make the same fields mandatory at another point in the system.
Resolution
You can edit the appointment on C4C side and fill out the mandatory fields.
You can also post this request in the influence side if you consider that Outlook behaviour needs to be changed: https://influence.sap.com
Keywords
mandatory field, outlook, appointment, account, activities, , KBA , LOD-CRM-ACT , Activities , Problem