SAP Knowledge Base Article - Public

2616292 - Appointments can be Created from Outlook Without Filling in the Mandatory Fields

Symptom

You set up some fields to be mandatory in an appointment.

When you create an appointment from C4C, the system won’t let you save the appointment until these mandatory fields are filled in.

However, if the appointment is created from Outlook, the same fields will not be mandatory and outlook will be able to save these appointments without filling in the same fields.

Environment

  • SAP Add-In for Microsoft Outlook
  • SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the activities work centre.
  2. Go to the appointments view.
  3. Click on New.

    Result: You can see field ABC which is mandatory. In this example, we use the field Account.

    AccountMandatory.jpg

  4. Log in in the Outlook add in.

  5. Go to the calendar view.

  6. Click New appointment.

  7. Click Add appointment.

  8. Click Submit.

    AccountNotMandatory.jpg

    Result: You can save the appointment without entering an account. Consequently, this appointment will appear in the system without the compulsory information.

Cause

This is the current system’s behaviour. Fields which are made mandatory in the system won't become mandatory in Outlook.

One view having mandatory fields does not automatically make the same fields mandatory at another point in the system.

Resolution

You can edit the appointment on C4C side and fill out the mandatory fields.

You can also post this request in the influence side if you consider that Outlook behaviour needs to be changed: https://influence.sap.com

Keywords

mandatory field, outlook, appointment, account, activities, , KBA , LOD-CRM-ACT , Activities , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions