Symptom
You replicate customers/business partners from ERP/S4 to your SAP Cloud for Customer (C4C) system and the following error occurs in Web Service Message Monitoring:
Code list mapping for region code ABC in countryXYZ is missing (where ABC is the region code and XYZ is the country).
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center and select Web Service Message Monitoring.
- Select a failed message and choose View >Error Log.
- Observe the error: Code list mapping for region code ABC in countryXYZ is missing.
Cause
The error occurs due to missing code list mapping for the respective region codes.The region codes in C4C have context assigned to them, which is the country code. A region code may occur multiple times. In order to uniquely identify a regional code, it has to be considered in the context of the country.
Resolution
You need to maintain the code list mapping (in Business Configuration) for the time zone as follows:
- Go to the Business Configuration work center and click on Overview.
- Search the configuration element Code List Mapping for Integration with External Applications and Solutions.
- Click on Maintain Code List Mapping.
- Under Code List Mapping Definition select RegionCode for Local Data Type Name.
- Under Code List Mapping Rule, click Add Row.
- Select Local Context, i.e. desired country code (XYZ).
- Under Code List Mapping Rule select Mapping Rule = Local And Remote Codes Are Equal.
- Once you select the mapping rule, mapping rows are automatically added to the table.
- Then change the rule to Map Individual Codes.
- You can add/edit now the existing mappings for the region codes specific to the country.
See Also
2652331 - RegionCode is Not Present by Default in Code List Mapping
Keywords
ERP Integration with C4C; S4 Integration with C4C; RegionCode; , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , How To