SAP Knowledge Base Article - Public

2616657 - Extension Field Defined On A Custom BO Cannot Be Added In Determine Service Level Rule of Ticket

Symptom

You have defined an extension field on a custom business object via PDI, but cannot add this field as a parameter in Determine  Service Level Rule of Tickets.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1.  Go to Administrator workcenter
  2.  Navigate to Service and SocialSLA Setup → Determine Service Level
  3.  Select the rule, and click on Adapt Columns
  4.  Try to add the extension field defined on the custom BO
  5.  The extension field is not available in the Decision Table Configuration pop-up and hence, the field cannot be added as a parameter

Cause

In the Determine Service Level rule, we only support extension fields on the BO Service Request and not from other custom BOs.

Resolution

This is the current system behavior of SAP Hybris Cloud for Customer.

See Also

If you have a business use-case that requires a change in the existing system behavior, please raise your requirement on the SAP Hybris Cloud for Customer Influence Site : https://influence.sap.com/SAPCloudforCustomer

Keywords

custom field, extension field, determine service level, SLA setup, service rules, PDI fields cannot be added, Ticket SLA configuration , KBA , service level , sla configuration , determination rule , extension fields sla , LOD-LE-CSM-SVL , Service Level Objective , LOD-CRM-SRP-UI , Ticket Related UI , Problem

Product

SAP Cloud for Customer add-ins 1802