Symptom
An extension field defined on a custom business object via PDI cannot be added as a parameter in the Determine Service Level rule for Tickets.
Environment
SAP Cloud for Customer core applications
Reproducing the Issue
- Go to the Administrator work center.
- Navigate to Service and Social → SLA Setup → Determine Service Level.
- Select the rule and click on Adapt Columns.
- Attempt to add the extension field defined on the custom business object.
Result:
The extension field is not available in the Decision Table Configuration pop-up and therefore cannot be added as a parameter.
Cause
In the Determine Service Level rule, only extension fields from the Service Request business object are supported. Extension fields from other custom business objects are not supported.
Resolution
This is the current standard system behavior.
Keywords
Custom Field, Extension Field, Determine Service level, SLA setup, Service Rules, PDI Extension Fields Not Supported, Ticket SLA Configuration, Service level Determination Rule, SLA Configuration, Extension Fields in SLA , KBA , LOD-LE-CSM-SVL , Service Level Objective , LOD-CRM-SRP-UI , Ticket Related UI , Problem
SAP Knowledge Base Article - Public