Symptom
When trying to complete a survey some Users are unable to see any questions or answers from the survey.
Environment
SuccessFactors Learning Management System (LMS)
Reproducing the Issue
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Create a Questionnaire Survey;
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Associate it with an Item;
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Assign the Item to the user;
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User completes the item;
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User Opens the survey, however there are no question or answer available.
Cause
The questions and answers were not created for the Users' Locales.
Resolution
Create the questions and answers in the Users' locale as well. There is no functionality to make it automatically available in all languages, however when creating or editing it, an Admin can populate the data in all locales.
- Go to Learning->Questionnaire Survey;
- Create a new one or edit an existing one (note that for editing you will need to create a new draft);
- Go to Questions;
- Click in the small globe next to the field in the original Locale (here is where a new draft will need to be created for already existing and published surveys);
- It will list all the available Locales and the text for each one next to it;
- Edit/Populate it and Save.
See Also
2423652 - Survey details show "no description" for the user
2546172 - Changing an Evaluation on an Existing Item
Keywords
Locale, Empty, Answer, Question, Title, Questionnaire Survey, Translate, Language , KBA , LOD-SF-LMS-LAN , Language Packs & Translation , Problem