Symptom
While updating Address Information for a User or Dependent in either;
a) The Add New Employee wizard, while navigating from 'Identity' to 'Personal Information'
b) Address Information portlet of a user's Employee Profile
c) Dependents portlet of a user's Employee Profile
...you get an application error with fingerprint=dbb49b21ec36b71bd9b9688c1b68b8f60df7c219 while saving the information
Environment
-
Employee Central
- Picklists Management
- Picklists Center
- Add New Employee
- Employee Profile
- Dependents Management
Reproducing the Issue
a) The Add New Employee wizard, while navigating from 'Identity' to 'Personal Information';
1. Navigate to Admin Centre > Add New Employee
2. Complete 'Identity' section > Click 'Continue' > Application Error occurs
b) Address Information portlet of a user's Employee Profile;
1. Navigate to a user's Employee Profile > Edit 'Address Information' portlet
2. Update Address Information > Click 'Save' > Application Error occurs
c) Dependents portlet of a user's Employee Profile
1. Navigate to a user's Employee Profile > Edit Dependents' portlet
2. Update Dependent information > Click 'Save' > Application Error occurs
Cause
This error is caused by blank Enternal Codes in the 'AddressType' picklist
1. Navigate to Admin Centre > Picklists Management > Export the Picklist File
OR
Navigate to Admin Centre > Picklist Center
2. Seach for the Picklist ID 'addressType'
3. Look at the values maintained under 'External Code' > One or more are missing
Resolution
You must maintain values in the External Code field of the picklist.
Keywords
dbb49b21ec36b71bd9b9688c1b68b8f60df7c219, Add New Employee, Dependents, Address Information, Picklist, Application Error, STE-5067 , KBA , LOD-SF-EC-BCI , Manage Business Configuration (BCUI) & Data Models (XML) , Problem