Symptom
You have automatically added some products in a sales quote/order using a web service or a PDI. When you open this sales quote/sales order, you see the message 'Product not valid; it is blocked'.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
- Go to the Sales work centre.
- Go to the Sales Quotes or Sales Orders view.
- Open Sales Quote ABC (ABC being the name of your sales quote).
Result: The message 'Product not valid; it is blocked' pops up.
Cause
The webservice or PDI added a product which is blocked in the system.
Resolution
- Go to the Products work centre.
- Go to the Products view.
- Open the product which is blocked.
- Click on Actions > Activate.
Result: The message inside the sales quote/order disappears.
Keywords
product, blocked, Product not valid, sales quote, sales order, , KBA , LOD-CRM-PRO , Products , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions