SAP Knowledge Base Article - Public

2617406 - Not all the Rules Defined in Sales and Campaign Settings will be Displayed in the List

Symptom

You define a large number of rules in Sales and Campaign Settings. After all these rules are created, you realize that not all of them appear on the list.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the Administration work centre
  2. Go to the Sales and Campaign settings.
  3. Click on one of the rules defined there, for instance Define Rules for Lead Assignment.

    Admin_Rules.jpg
  4. Create a large number of rules (for example, 1000 rules).

    Result: UI displays a warning message 'The data cannot be displayed completely. Sorting and Filtering are not reliable since the number of hits is too large. Reduce the number of search hits by restricting the search criteria'.

Cause

There is a UI limitation to display a large number of rules in the list. However, all the rules are always executed.

Resolution

You can download the list in Excel. You will be able to see all the rules in the excel document.

DownloadOption.jpg

Keywords

rule, lead assignment, opportunity parties, deal registration, sales quote parties, territory realignment, Sales and Campaign settings, , KBA , LOD-CRM-LM , Lead Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions