SAP Knowledge Base Article - Public

2617581 - When using to the Include Operator to Define Rules for Parties, no Data is Available to Choose From

Symptom

For certains Columns, the respective data cannot be found in the operator pop-up window when using the operator Include to add a non-consecutive number of entries in Party Rules Determination.

Environment

SAP CLOUD FOR CUSTOMER

Reproducing the Issue

The following steps are only an example. The same behaviour can happen when defining rules for other parties (such tickets, sales quotes...)

  1.  Go to the Administrator workcenter.
  2.  Go to the Sales and Campaign Settings view.
  3.  Click on Define Rules for Opportunity Parties
  4.  Click on Add Row.
  5.  Click on the asterisk under the column you want to use as criterium for your rule (for example, Sales Org ID).
  6.  In the Operator window, select the operator Include from the dropdown list.

Result : There is no entry to choose from.

Cause

For Columns returning huge amount of data (like Sales Org IDs , Account IDs , Territory IDs) the operator Include is not made available.

The reason behind this coding of the system in that area is to avoid huge data retrieving that could lead to performance issues and even result in system dumps.

Resolution

You need to add the entries manually by clicking on Add Row and maintain each entry manually, using the operators Equal. or maintain a consecutive range of entries with the operator Between.

Keywords

Opportunity Party Rules, Define Opportunity Parties, Operator, Include, Between, Equal. , KBA , LOD-CRM-OPP , Opportunity Management , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions