Symptom
You are using GenerateNextPersonID to generate new Ids and the Ids generated are duplicates when API calls are triggered by multiple users concurrently.
Environment
Successfactors HCM Suite
Reproducing the Issue
NA
Cause
This can happen in the following scenarios:
-
Hires are processed by concurrent API calls.
-
During peak times when a high volume of hires are processed by multiple users at the same time.
Resolution
To Avoid this we recommend the following:
Enable Database Sequence to generate next Employee Id option to change the process how employee IDs are generated.
To enable this feature:
- In Admin Center, Access Company System and Logo Settings.
- Check the box for Enable Database Sequence to generate next Employee Id.
- Save the changes.
Now Instead of creating the IDs based on the SYS_CONFIG table, they are generated based on a database sequence.
Keywords
Duplicate Person IDs, GenerateNextPersonID, Duplicate employee Ids , KBA , LOD-SF-INT-ODATA , OData API Framework , LOD-SF-INT , Integrations , Problem