Symptom
When cancelling the Service Order ABC the following error message is displayed and saving is not possible: 'You cannot change the data in Cancellation Reason. Refresh screen and try again'
Environment
SAP Business ByDesign
Reproducing the Issue
-
Go to the Service Order work center.
-
Select the Service Order Processing view.
-
Search for the Service Order ABC (This represents the number of the serivce order).
-
Click on the Edit and then the View All button.
-
On the header level enter a Reason for Rejection.
-
The following error message is displayed: You cannot change the data in Cancellation Reason. Refresh screen and try again.
Cause
You are facing this errror due to a missing reason for rejection on the Service Confirmation document.
Resolution
-
Go to the Field Service and Repair work center.
-
Select the Service Confirmation view.
-
Search for Service Order ABC.
-
Click on the Edit and then the View All button.
-
Enter a Reason for Rejection.
-
Save
- Go back to the Servicer Order ABC
- Remove the Reason for Rejection and enter the reason for rejection again.
The status of the Service Order will change to Completed.
Keywords
KBA , SRD-CRM-ORD , Orders & Contracts , How To
Product
SAP Business ByDesign all versions