Symptom
You cannnot delete Started service items in work tickets.
Environment
SAP Cloud For Cutsomer
Reproducing the Issue
- Go to the Services work center.
- Go to the Work Tickets view.
- In the search field enter ABC(where ABC is the Ticket Id) and open it.
- Go to the Service and Repair facet and line-item YY(where YY is line number) .
- Press delete icon under the Action column.
You can see the error The item can't be deleted as its Work Progress is no longer Open/Ready.
Cause
The task will be editable only if the Work Progress of item YY is with status as Open/Ready ,not for other status such as Started. This also means that technician assigned to item is already working so it cannot be changed during progress.
Resolution
This is an expected system behavior. Once Items are released to External systems, they can no longer be deleted.
Keywords
Work Progress Status, not able to delete work ticket item , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To