SAP Knowledge Base Article - Public

2618205 - Ready to Hire is set to NO, and not changing to Yes - Onboarding

Symptom

 When you check the OCI the Ready to Hire is No when it should be Yes

Environment

SAP SuccessFactors Onboarding 1.0

Reproducing the Issue

  1. Go to Admin Center
  2. Search Manage Data
  3. Search for OnboardingCandidateInfo
  4. Search for the affected Candidate
  5. Check the "Ready to Hire"  status and it is set to "No"

Cause

The following are the possible causes for this issue:

  1. Hiring Manager (Named users) assigned for that candidate are not present in BIZX.
  2. If Hiring Manager is exist, He does not have the permission to see the Candidates in Manage Pending Hire Queue.
  3. SF Notifications is not active in super admin.
  4. SF Bizx Connection is not active in super admin.
  5. BX Auth value is not setted for customer Instance in super admin.
  6. Manual Kick start from ONB.Kicking onboarding process from onb process tab
  7. Check the candidate status in Manage data-if hired status is yes,then candidate will not appear.
  8. Make ensure in edit applicant status configuration-one status should be hired and one should be hireable.
  9. A database query timed out and was not able to insert a record.

Resolution

The following are the possible resolution for this issue:

  1. Check whether the hiring manager assigned for candidate is available in BIZX . If you see 403 error in theSF_Integration, that means the Hiring Manager of the particular candidate is not available in BizX
  2. Check whether that hiring manager has the manage pending hire permission to see the candidate.
  3. Generally, SF_Integration in audit trail in status Failed(500 Internal Error).So please check whether in super admin site whether this feature is active.
  4. Check whether Bizx Connection is active in super admin site.
  5. It should be setted in super admin.For each instance, there will be an authentication value.If this not set, details will not flow to manage pending hires. Account options--type for key auth and value should present.
  6. If the activity is created from ONB, (Manual kick starting from process tab, and not from RCM, then the flag "EnableExternal ATS-ONB-EC Integration" has to be enabled in BizX provisioning.
  7. Please make sure the status of candidate is in ready to hire--Yes and Hire status is-No.
  8. Customer may have multiple HIRABLE STATUS HERE, please make sure you have only one.
  9. This can be due to unexpected high load on the database server, please check KBA 2829740 for how to proceed).

See Also

 KBA 2829740 - "readyToHire" Field did not Update to "Yes" After New Employee Step due to Database Query Time-out [Integration with BizX] - Onboarding 1.0

Keywords

OCI, OnboardingCandidateInfo, Read to Hire , KBA , LOD-SF-OBD , Onboarding , Problem

Product

SAP SuccessFactors Onboarding