Symptom
You want to filter the Service Performer on Service Orders using the 'Function' and 'Department' columns, but while searching for the service performers, you see that both columns are empty.
Environment
SAP Business ByDesign 1802 and higher.
Reproducing the Issue
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Hover the mouse pointer over the Service Orders work center.
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Click on New Service Order.
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Click on the value help from field 'Service Performer'.
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Search for the employee.
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See columns 'Function' and 'Department' are empty.
Cause
The reason for the fields being empty is that you are searching for Employees, instead of Service Agents. The fields 'Function' and 'Department' are linked to the Service Agent master data, they are part of the Business Details of a Service Agent.
Resolution
To maintain information on 'Function' and 'Department' fields, follow the steps below:
- Go to the Supplier Base work center, in Service Agents view.
- Search for the desired Service Agent and edit it.
- If the Service Agent has already a Supplier determined, both Function and Department fields will be editable.
- If the Service Agent has no Supplier determined, both fields will be read only.
- You should determine a Supplier for the Service Agent and then update both fields.
Keywords
function, department, service agent, supplier base, service order, service performer , KBA , SRD-MD-BP , Business Partner , How To