Symptom
You see English language values for Drop Down List Extension Fields on login via another language such as German or Chinese
Environment
SAP Cloud for Customer
Reproducing the Issue
- Log into System in desired language (for example: German).
- Suppose that you have added the Extension Field to Service Tickets screen.
- Navigate to Service -> Tickets.
- Open any Ticket.
- Enter Edit Mode.
- Click Drop Down List menu of the field.
- You see that the Drop Down List Values appear in English instead of German.
Cause
Language Translations for Code List Values have not been maintained for the Extension Field.
Resolution
- Log into the system.
- Navigate to Service > Tickets.
- Open any Ticket.
- Enter Adaptation mode.
- Edit the field.
- Navigate to General Data tab.
- Maintain the list of languages that you require in Screen Texts Table by clicking on Add Row button.
- Add new values to field by Clicking on Add Row button for List Values.
- Maintain Translations for each row through Description of List Value.
Keywords
Code List Values, Extension Field translation, no translation for extension field , KBA , no translation for extension field , code list values , extension field translation , AP-RC-UIF-FLX , Page Layout & Key User Configuration , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions