Symptom
You have saved the phone number in customer contact with country code prefix +91 1234567890 but country code +91 got disappeared in payload and prefix leading zero added in the original phone number.
Environment
SAP Hybris Cloud for Customer.
Reproducing the Issue
- Go to the Customers work center.
- Open relevant account & update contact details with country code prefix i.e. +91 123456789
- Go to the Web Service Message Monitoring.
- Find the relevant message having Service Interface BusinessPartnerERPContactAddressReplicationOut.
- You will find the phone number as per below node representation.
<DefaultConventionalPhone>
<SubscriberID>0123456789</SubscriberID>
<CountryCode>IN</CountryCode>
</DefaultConventionalPhone>
Cause
This is due to the way ERP system save the contact as +91 is changed to country code IN & trunk prefix, a single digit – often a ‘0’ – that needs to be prefixed to the phone number whenever a domestic call is made.
In the stated example India has a trunk prefix of ‘0’, so the structured representation is
CountryCode: IN
SubscriberID: 0123456789
This actually gets formatted to +91 0123456789.
Resolution
System works as designed.
See Also
Keywords
Phone number formatting, , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem