Symptom
A Sales Order is being released under the Customer Demand view, but the Sales Order is blocked.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Outbound Delivery Control work center.
- Select the Customer Demand view.
- Search for the Sales Order ID ABC (ABC represents the ID of the Sales Order).
- Under Delivery Block, the status is Blocked.
Cause
There are 3 possible reasons:
Cause 1: The Delivery Block has been maintained in the Sales Order.
Cause 2: The Sales Order is blocked because the Sales Order Approval Process is in scope and the approval status in the Sales Order is Not Started.
Cause 3: The Sales Order is blocked because at the time the document was created or last modified, an active Sales Order Approval Process was in place. Since the document was not approved and the Sales Order Approval Process has since been de-scoped from the system, it cannot be sent for approval and remains blocked.
Resolution
Cause 1:
To solve the issue you need to remove the Delivery Block in the Sales Oder.
- Go to the Sales Orders work center.
- Select the Sales Orders view.
- Search for the Sales Order ID ABC.
- Click the Edit button.
- Navigate to the General tab.
- Remove the value in the Delivery Block field.
- Save your changes.
Cause 2:
Step 1: Re-scope the Sales Order Approval Process.
- Go to the Business Configurations work center.
- Select the Implementation Projects view.
- Click the Edit Project Scope button.
- Navigate to the Questions tab.
- Expand the Sales Orders option.
- Expand the Selling Products and Services option.
- Select the Sales Orders option.
- Check the checkbox for the question: "Do you want to use a multi-step approval process for sales orders?"
- Confirm changes.
Step 2: Submit the Sales Order for Approval.
- Go to the Sales Orders work center.
- Select the Sales Orders view.
- Search for the Sales Order ID ABC.
- Click the Edit button.
- Click the Submit button.
- Select the Submit for Approval option.
Step 3: Approve the Sales Order if an approval is necessary according to the criteria in your approval process.
Once the Approval Process in the Sales Order has changed to Approved or Approval not Necessary the Delivery Block in the Customer Demand will no longer be Blocked.
- Go the the Customer Demand view.
- The Sales Order should no longer blocked.
You can then also de-scope the Approval Process if it is no longer required.
Cause 3:
To solve the issue you need to trigger and complete the Approval Process.
Step 1: Submit the Sales Order for Approval.
- Go to the Sales Orders work center.
- Select the Sales Orders view.
- Search for the Sales Order ID ABC.
- Click the Edit button.
- Click the Submit button.
- Select the Submit for Approval option.
Step 2: Approve the Sales Order if an approval is necessary according to the criteria in your approval process.
Once the Approval Process in the Sales Order has changed to Approved or Approval not Necessary the Delivery Block in the Customer Demand will no longer be Blocked.
- Go the the Customer Demand view.
- The Sales Order should no longer blocked.
See Also
KBA 1833775 - You Have Scoped The Approval Process For Sales Order And Your Customer Demand is in Status 'Delivery Blocked'
Keywords
Sales Order blocked, Customer Demand cannot be released, Delivery Status blocked; Customer Demand, Sales Order, Delivery, Release, Blocked, Sales Order Approval Process, Outbound Delivery, Sales Order Configuration, Implementation Projects, Sales Order Status, Approval Status , KBA , AP-SLO-SO , Sales Order , How To
SAP Knowledge Base Article - Public