Symptom
Customer has implemented the integration RM to EC, the mapping work for an external candidate but NOT for Internal Candidate although the information is not mapped as expected (eg. position number is not updated as well as the organization fields such as legal entity etc...)
Environment
Recruiting Management - Internal Hire
Employee Central - Manage Pending Hire
Reproducing the Issue
- From Admin centre go to Manage Pending Hire
- Choose an Internal Hire
- Proceed with hiring
- in the Job Info section it is expected that the position should change to the new position but this is not happening. The position is instead set to Null.
- it is also expected that Organisational fields should default to the Position configure in RCM but is not happening either.
- The position is set to null and the Organisational fields displayed are that of the old position.
Cause
Legal Entity Change - is caused by a rule set in Company / Legal Entity which is ressetting this field to NULL OnChange .
This rule is setting position as Null whenever Company is sent from RCM for internal hire. Whereas this issue won't occur for External hire, because company sent from RCM is in identity page and onchange rule is not triggered.
Resolution
Please remove the onchange rule from Company / Legal Entity in Manage Business Configuration, and all should work as expected
Keywords
Postion, Legal Entity Change, Organisational fields , KBA , LOD-SF-EC-INT , Manage Pending Hires (Integration RCM/ ONB/ OBX + UI) , LOD-SF-RCM-INT , Integration Center & Intelligent Services , Problem