Symptom
Submit for Approval and Withdraw from Approval options are not available despite Approval processes being scoped.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite: You have scoped Approval processes for your system and created an active Approval with conditions which are met in your object ABC (ABC represents the object name).
In this example we will use Opportunities, however, the issue is not restricted to Opportunities.
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Go to the Sales work center.
- Go to the Opportunities view.
- Open your opportunity ABC which fulfils the conditions maintained in your Approval process.
- The options Submit for Approval and Withdraw from Approval are not available.
Cause
You have configured Custom Statuses to be used with this Opportunity document type. In case the opportunity uses a custom status, the ability to submit for approval must be explicitly configured in the Business Configuration (BC) fine-tuning to allow the submitting of the custom status that the opportunity is in. Only if the opportunity is in a custom status that allows approval submission will the actions be available.
Resolution
You need to allow the Submit for Approval action for each custom status:
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Go to the Business Configuration work center.
- Open the Fine Tuning activity Opportunities.
- Open Maintain Custom Status.
- In the list of custom statuses there is a column titled Submit for Approval.
- Here, please check the box for each status which you want to allow the Submit for Approval action for.
See Also
SAP Hybris Cloud for Customer Administration Guide
Keywords
Submit for Approval, Withdraw From Approval, Greyed Out, cannot submit for approval, custom status, , KBA , approval , LOD-CRM-OPP , Opportunity Management , Problem