Symptom
Automatic assignment of tasks and/or surveys for opportunities and/or leads using routing rules not working.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisites:
You have already created an Activity Plan and added tasks to it.
Phase I:
- Go to the Activity Planner work center.
- Select the Routing Rules view.
- Click the New button in order to create a new routing rule.
- Fill in the required fields.
- Choose the Opportunity value for the Business Application field.
- Click the Save and Open button.
- Define the conditions, under the Conditions facet.
- Assign the previously created plan, under the Activity Plans facet.
- Save the changes and activate the rule.
Phase II:
- Go to the Sales work center.
- Select the Opportunities view.
- Create a new opportunity, which meets the conditions set up in the routing rule.
- Select the Sales Activities facet.
- You can see that no task was automatically assigned to the opportunity.
Cause
The tasks and/or surveys maintained in the activity plan will only be assigned if you press the button "Actions -> Refresh Activity Plan".
Resolution
This is the system expected behavior.
If you need to have automatic assignment of tasks/surveys from the activity plan as soon as the conditions are met, you need to create a workflow rule, following the steps below:
- Go to the Administrator work center.
- Go to the Workflow Rules view.
- Press New to created a new workflow rule.
- Select the business object (Opportunity/Lead) and define timing.
- Press Next.
- Maintain the relevant conditions.
- Press Next.
- Maintain as below:
Rule Type: Action
Select Action: Refresh from Activity Plan - Press Next.
- Finish the workflow rule and save it.
Keywords
Activity Routing Rule, Activity Plan, Opportunity, Lead, Conditions, Tasks, Survey, assign automatically , KBA , LOD-CRM-OPP , Opportunity Management , LOD-CRM-ACT-ROT , Activity Routing , How To