Symptom
In the Ticket UI, there are 3 different fields available for Customer: Customer, Account and Individual Customer. They all have different OVS (Object Value Search).
Environment
SAP Hybris Cloud For Customer
Reproducing the Issue
- Go to the Service work centre.
- Go to the Tickets view.
- Open Ticket ABC (ABC represents the ID of the Ticket) OR click New OR click New Ticket on the sidebar.
- Notice there are 3 different Customer fields: Customer, Account and Individual Customer. Each of them have different value help options.
Note: By default only one Customer field is visible and the other two are hidden. They can be made visible using Personalization or Edit Master Layout options, you can show/hide the fields via Adaptation using KUT.
Cause
- The Customer field maps to the value help Customer_OVS which does not respect the access context and shows all Customers (Account + Individual Customer).
- The Account field maps to the value help Account_SOVS which respects the access context based on the Account work centre view and shows only Customers of type Account.
- The Individual Customer field maps to the value help IndividualCustomer_OVS which respects access context based on Individual Customer work centre view and shows only Customers of type Individual Customer.
Resolution
This is expected system behaviour.
Keywords
Ticket, Customer , KBA , LOD-CRM-ACC , Account , Problem
Product
SAP Cloud for Customer add-ins 1802