SAP Knowledge Base Article - Public

2620739 - Snap Engage Chat URL Hyperlink Does NOT Appear in the Ticket

Symptom

You have completed the configuration for the Snap Engage function, but you cannot see the Insert: Chat URL hyperlink in tickets.

Reproducing the Issue

  1. Go to the Services work center.
  2. Go to the Tickets view.
  3. Open any ticket.
  4. The Insert: Chat URL hyperlink below the reply box is not visible.

Cause

To enable the Snap Engage function, you have to check the following settings.

1. Enable API in Business Configuration.
Business Configuration -> Implementation Projects -> select the project and click Edit Project Scope -> Scoping-> Under Communication and Information Exchanged-> Business Process Management -> select Application programming Interfaces (APIs).

2. Create communication systems for SNAP_ENGAGE.
Administrator work center -> Communication Systems -> maintain the communication system for Snap Engage and make it Active.

3. Define the communication arrangement.
Administrator work center-> Communication Arrangement -> maintain the arrangement for Snap Engage, write down the User ID of this arrangement.

4. Admin setup in Snap Engage website.
Use your admin user to login to the Snap Engage website-> create the integration between Snap Engage and SAP Social Customer Engagement OnDemand.

  • Service Address: maintain the C4C URL which you want to connect with Snap Engage.
  • User: copied from step 3.

Create Agent and then click Get the Code -> copy the code from between js. This is the API key.

5. Mashup Web Service in C4C.
Administrator work center -> Business Flexibility -> Mashup Web Services -> select the service and click Enter API Keys -> click Show API Keys -> maintain the API which copied from step4 .

In this particular case, chat provider setting is not properly maintained. The Service ID was typed wrongly. Instead of BYD_COD/SNAPENG, this was typed BYD_COD\SNAPENG.

Resolution

Follow the steps below to correct the Service ID.

  1. Go to the Administrator work center.
  2. Go to the Service and Social view.
  3. Open Chat Provider under section Communication Channels.
  4. Correct the Service ID for API, make sure it is BYD_COD/SNAPENG.
  5. Save the change.

 

Keywords

Snap Chat, URL Hyperlink on chat , KBA , LOD-CRM-SC-CHA , Chat , Problem

Product

SAP Cloud for Customer add-ins 1802 ; SAP Hybris Cloud for Customer add-ins 1702