Symptom
"There was an error retrieving data. Please contact support" while attempting to validate a form
Environment
- SAP SuccessFactors Calibration
- SAP SuccessFactors Performance & Goals
Reproducing the Issue
- Create a Calibration Session
- Configure Calibration template to
- Validate the session and route the forms
- The error message is received
Cause
If you search for the calibration session ID and company ID in splunk, the resulting error message should read:
There was an error routing the subjects with session id: 4483 com.successfactors.sca.service.exception.ServiceUpdateFailedException: error when force route form.
If you expand the error message, you will see the cause:
com.successfactors.workflow.util.workflow.FormRoutingException: Recipient was not found.
At least one subject's calibration step is for a role that does not exist
Resolution
Remove the affected subject from the calibration session:
- Go to Admin Center > Calibration > Manage Calibration Sessions
- Choose the affected calibration session
- Click on the People tab, then Subjects
- Select the offending user
- Click Delete
If you're unsure which user is the problem, run an Employee Profile adhoc report, and be sure to include the missing role as the column, along with that role's status
Keywords
KBA , LOD-SF-CAL-PM , Calibrating with Performance Form Data , Problem
Product
SAP SuccessFactors HCM Core 1711