Symptom
How to troubleshoot business rules in EC
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HXM Suite
- SAP SuccessFactors Employee Central - Business Rules
Reproducing the Issue
Customer has created a Business Rule in Employee Central but does not get the expected result.
Cause
The below steps will help identify and eliminate configuration issues.
Resolution
- Enable rule trace from admin centre, and make sure that the rule is actually triggered.
- If the rule is not triggered then check
- If it has the proper base object
For example:
- If you want a rule to trigger in Job Information where you want to set/check the data of the fields, then select Job Information.
- If you want to trigger the rule in Job information where you want to hide the fields/make the fields mandatory, then in this case you will need to access Data Model attributes of the Job Information fields. use Job Information Model as the Base Object and so on.
- If it is associated with correct event
- Make sure no additional parameters are added to the rule which are used in one of the IF/SET statements
- If rule is accessing other entities with navigations from employment details, make sure those other objects are accessible.
- For example: in case of new hire, other objects are not yet saved to DB, so such navigations will not work.
- If the rule is setting values to other entities, make sure cross portlet rules are supported for those entities. As of now, cross portlet rules are supported for employment related entities only.
- If the rule base object is "Employee information" or "Employee information model", those rules will be triggered on new hire/rehire only.
- If both Job and Compensation are updated from take action, order of rule execution is as below.
- a. Job info onsave rules
- b. Comp info onsave rules
- c. Job info onsave rules
Please Note: Onsave rules are executed at the time of workflow initiation, not at the time of approving the final step of the workflow
Please raise an case if further assistance is needed - Provide clear steps to replicate the issue as well as configuration details (rules, workflows, screenshots etc.)
FAQ - Additional Information
Q) Where can I get Guide?
See Also
Keywords
Business rules, Troubleshooting, rule , employee central , KBA , LOD-SF-EC-JOB-RUL , Job Info Business Rules , LOD-SF-EC , Employee Central , LOD-SF-EC-CMP-RUL , Business Rules , How To