Symptom
You have assigned a View ID to a user in order to give them access to a Common Task, however when they access the system, they are not able to see this Common Task under the respective Work Center.
Environment
SAP Business ByDesign 1802 and higher.
Reproducing the Issue
Administrator assigning the Common Task to the user:
-
Go to the Application and User Management work center.
- Open the Business User view.
- Select the user.
- Click on Edit -> Access Rights.
- Open Work Center and View Assignment tab.
- Expand the work center of the Common Task.
- Assign the Common Task to the user.
- Save it.
User not able to see the Common Task:
- Go to the respective work center;
- The only views available are Overview and Reports. There are no Common Tasks showing.
Cause
In order for the Common Tasks to be available in the work center, the user needs to have one of the views of this work center assigned.
Resolution
Assign one of the views of the work center to the user, then they will be able to access the tasks.
Also note that by doing this, all of the Common Tasks will be available for them, it is not possible to release only specific tasks.
Keywords
common tasks, work center, assignment, business user, access rights, work center view assignment , KBA , SRD-CC-IAM , Identity & Access Management , How To