Symptom
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
You are trying to set a Ticket as a Work Ticket. The field Requires Work is read-only.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Service work centre.
- Go to the Tickets view.
- Open the Ticket ABC (ABC represents the ID of the Ticket).
- You notice that the field Requires Work is read-only.
You expect that you can set the Ticket to Requires Work.
Cause
This is the expected system behaviour.
In Ticket Screen, Requires Work flag is read-only, which is used to identify Work Tickets. Work Tickets are standard Tickets with the Requires Work flag set.
Resolution
You have the following options to resolve the issue:
Option 1: Requires Work flag can only be set during the Ticket creation in Ticket Quick Create Screen.
To create Work Ticket with Requires Work flag on:
- Go to the Service work centre.
- Go to the Tickets view.
- Select New.
- Select Requires Work checkbox.
- Click Save and Open.
Option 2: Once the Ticket is created, the Requires Work flag can be set by selecting the Ticket's Status as Requires Work (or in case your administrator has changed the naming, the Status that has Planner Action assigned in Business Configuration).
To set the Status of a Ticket as Requires Work:
- Go to the Service work centre.
- Go to the Tickets view.
- Open the Ticket ABC.
- Click Edit.
- Select Status Requires Work.
- Click Save.
See Also
SAP Cloud for Customer User Stories - Work Tickets: https://help.sap.com/viewer/e3d4d4173c6f4231a6a35885511484ee/1802/en-US/9e15b6131eb94605ae4f793a9fc62811.html?q=requires%20work
Keywords
Ticket, Work Ticket, Requires Work, Planner Action , KBA , planner action , work ticket , requires work , LOD-CRM-SRP-UI , Ticket Related UI , How To