SAP Knowledge Base Article - Public

2623951 - Missing Data on Remittance Advice With Direct Posting to G/L Account

Symptom

You have created an Outgoing Check and generated the preview of a Remittance Advice. The created PDF file does have the check ID and amount, however you are missing the Document Number, Document Date and other item information in the file.

Environment

SAP Business ByDesign.

Reproducing the Issue

  1. Go to the Payment Management work center.
  2. Go to the Payment Monitor View.
  3. Click to open an Outgoing Check.
  4. Click Preview -> Advice.

The system will show the Remittance Advice PDF for this check. Inside this PDF you are missing the Check's line item details as above described.

Cause

Considering you are using the SAP standard form template for remittance advice, the fields such as document number, document date, document type, payment amount, etc., are populated in the form template based on the payment explanation item, which in this case would be the invoice that the check has cleared. The document number would be the invoice's external reference, document date is the invoice's document date, and so on.

In this case, there is no invoice cleared against the check, instead a Direct Posting to G/L Account option has been used. For outgoing checks that has a direct posting to G/L account, there is no payment explanation item. Hence, the data is not populated in the form template, since there is not document being cleared but a G/L Account instead.

Resolution

This is the expected system behavior. The G/L Account data is not shown in the remittance advice details.

Keywords

Remittance Advice. Form Template. Outgoing Check. Open Item. , KBA , AP-PAY , Payment Processing , How To

Product

SAP Business ByDesign all versions