Symptom
You have multiple Group Templates maintained in the JAM, but when you try to create a Group in C4C from an Object, e.g. Account, you only have one option of Template to select.
Reproducing the Issue
-
Go to Customers Work Center -> Accounts View.
-
Open Account XXX(where XXX is the Account name).
-
Go to the Groups facet.
-
Click on “New”.
-
In the “Group Template” field see that you only have the option of “Account Management Template”.
Cause
When a you create group from JAM, there is no context available and hence all the generic Template are shown and one of them can be used.
For C4C and JAM Integration, the context is identified using the "Application Type" which is maintained during external applications creation. Basically the application type is "SAP Hybris Cloud for Customer". Under this external application, you can see three Records default types (Opportunity, Acocunt and Service Ticket) and each of them have their own template and these templates will be shown as per context. for e.g. If you try creating group for Account, only Account related templates which belong to "SAP Hybris Cloud for Customer" application type will be shown. Same for Opportunity and Service Ticket.
Resolution
This is the expected system behavior.
Keywords
JAM , Account , KBA , jam , c4c , group , LOD-CRM-ACC , Account , Problem