SAP Knowledge Base Article - Public

2624236 - Missing IDs in Business Partner Number Range

Symptom

When you create a new Business Partner, the numbering of the Business Partner id is not in sequence, i.e. some of the IDs are missing.

Reproducing the Issue

  1. Go to Business Partner Data work center
  2. Under Common tasks, select New Business partner
  3. After saving, you found that the Business Partner ID is not in sequence

Cause

The Business Partner ID is drawn during the Finalize (Step before saving) phase, afterwards still checks are performed (i.e. email address or postal code correct).
If the check is failing (due to some error message while saving) and the user exits the process, the ID is nevertheless Burned.

The same cause applies for External ID if the ID is not in sequence.

Resolution

This is expected system behavior. The system works as designed.

Keywords

Missing Business Partner ID, Number not in Sequence, Business Partner ID sequence , KBA , SRD-MD-BP , Business Partner , Problem

Product

SAP Business ByDesign all versions ; SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions