Symptom
- Apps cannot open on Fiori Launchpad
- Apps are missing in Fiori Launchpad
- Authorization errors occur in apps in Fiori Launchpad:
- You are not authorized to use transaction <T-Code> View Details
Environment
SAP S/4HANA Cloud Public Edition
Cause
- There are several causes related to KBA 2602149 that should be checked first
- If no Business Role Template is associated to a specific Business Role then you will not see inconsistencies mentioned in the Business Role Templates app
Resolution
- As mentioned in 2602149 , check the Business Role Templates app to look for roles that are different than the templates
- If you can still not see a specific app then go to the Maintain Business Roles app and select the role that should give you access to the app
- In the General tab there is a field for Template ID , and if this field is blank then the role is not associated to a template
- If you wish for the role to be associated with a template, then the role will need to be recreated from the template
- This will allow you to use the Business Role Templates method to check for inconsistencies in the future
- Alternatively, removing the catalog and adding it again will give you access to the specific application, and will give you the updated catalog
- This method will mean that the Business Role is still not associated to a Business Role Template which could cause issues in future releases
Keywords
authorization IAM Business Role Business Catalog Business Role Template , KBA , BC-SRV-APS-IAM , Identity and Access Management , Problem
Product
SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions