Symptom
You have enabled the Change History for a Custom Business Object you created on SAP Cloud Applications Studio and you realized it stopped working.
Environment
SAP Cloud for Customer - All its versions
SAP Business ByDesign - All its versions
SAP Cloud Applications Studio - All its versions
Reproducing the Issue
For the Custom Business Object you have created a screen. In this screen, the following scenario is reproducible:
1. Modify one of the fields you configured as relevant for the Change History.
2. Save the document/screen by clicking on button Save.
3. Check the Change History tab.
4. You will see no change logs registered for the changes you have just done.
Cause
This can happen due to mis-communication issues between SAP Cloud Applications Studio and the Backend.
Resolution
On SAP Cloud Applications Studio, take the following steps:
1. Open your Custom Solution.
2. Activate the Custom Business Object responsible for this Custom Change History.
3. Deploy Business Configuration of this Solution by right-clicking on the Solution name -> Deploy Business Configuration.
This will resolve the miscommunication issues and the Change History may work normally afterwards.
See Also
Blog post: Change History for Custom Objects -https://blogs.sap.com/2017/05/22/change-history-for-custom-objects/
Keywords
Change; History; SDK; Cloud; Applications; Studio; , KBA , change history , deploy business configuration , AP-RC-BDS-BO , ByDesign Studio BO definition/generation , Problem