Symptom
You try to replicate a sales document (sales order or quote) from your external system to SAP Cloud for Customer (C4C), but the message fails in Web Service Message Monitoring with the below error: 'RBAM: No authorization for 'Operation http://sap.com/xi/A1S/Global FindByElements' on 'ServiceInterface http://sap.com/xi/A1S/Global XXX'. (where XXX stands for the name of the interface)
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center.
- Go to Web Service Message Monitoring.
- Observe the Error Log for an erroneous message for interface: CustomerOrderProcessingQueryCustomerOrderIn. It would show a similar error as displayed below:
<ERROR_TEXT>RBAM: No authorization for 'Operation http://sap.com/xi/A1S/Global FindByElements' on 'ServiceInterface http://sap.com/xi/A1S/Global XXX'</ERROR_TEXT> (where XXX stands for the name of the interface, e.g.: CustomerOrderProcessingQueryCustomerOrderIn)
Cause
One of the root causes could be that the business user, who is trying to access the service CustomerOrderProcessingQueryCustomerOrderIn have not assigned to work center view COD_SALESORDER_WCVIEW (or respectively the one for sales quote).
Resolution
Assign the respective work center view to the user for authorization & send the message again from ERP.
Keywords
RBAM authorization missing, CustomerQuoteProcessingQueryCustomerQuoteIn, CustomerOrderProcessingQueryCustomerOrderIn , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To