Symptom
You are not able to base your Territory Realignment Run Rules on a KUT field created on the Sales Data facet of an Account.
You expect all extension fields available for selection in the Territory Routing Rules.
Environment
SAP Cloud for Customer
Reproducing the Issue
Example: You created a KUT field on the Sales Data facet of an Account.
-
Go to the Sales work center.
- Go to the Realignment Runs view.
- Click the Maintain Territory Rules link.
- Click Adapt Columns.
- The field you created is not available.
Cause
Only the Customer BO’s common node (the node where extension field defined on Customer BO reside) is exposed for territory rules adaptation. Sales Data extension fields are part of another BO (SALES_ARRANGEMENT), and thus will not be available for territory rules adaptation.
If a field appears available, but behaves differently to the field in the UI and was not created as Common Extension, please check if you may have another field with the same name maintained in the system that might be available instead.
Please further note, if you have an extension field with a dropdown list menu, the same list menu will be available within the Rules column.
Resolution
This is current expected system behaviour. For Territory Rules you have to use Customer Common Extension Fields only.
See Also
Territory Rules, not working, missing, wrong, KUT, PDI, extension, REalignment Run
Keywords
KUT Field, Account, Sales Data, Decision Table, Territory Management Realignment Rules , KBA , LOD-CRM-TM , Territory Management , LOD-CRM-ACC , Account , Problem