Symptom
You have mapped field Customer Group Code of S4 Hana system with Account Group field in Cloud for Customer system.
While creating or updating the customer in S4 Hana value of field Customer Group Code not sent to C4C system.
Environment
Cloud for Customer, S4 Hana, HCI Middelware
Reproducing the Issue
Create or update business partner from S4 Hana system to C4C with Customer Group Code.
Data is not updated in Account Group of respective customer in C4C system.
Cause
Issue is casued due to incorrect mapping in HCI Iflow S4_C4C_BusinessPartnerIn.
Correct values are being sent from S4 Hana system under the field NumberRangeIntervalBusinessPartnerGroup which is not mapped with Account Group.
Resolution
Delete the mapping of Customer Group Code & Account Group.
Change the mapping of Account Group with NumberRangeIntervalBusinessPartnerGroup.
Save the changes & re-deploy the iFlow.
Keywords
Customer Group Code Data is missing in XML message , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem