Symptom
Error message "No Supported Role for Business Partner" while replicating Business Partners to C4C
Environment
SAP Hybris Cloud For Customer
Reproducing the Issue
- Go to Webservice Message Monitor
- Select the failed message with service interface "BusinessPartnerReplicationIn"
- Navigate to error log
- Check the error message "No Supported Role for Business Partner XYZ"
Cause
There can be two reasons for this error message
- You have not maintained the code list mapping under BusinessPartnerRoleCode for the BusinessPartner Roles coming in Incoming message to C4C
- You have mainatined code list mapping, but the roles you are sending arent supported in C4C
Resolution
Solution for code list mapping issue
- Go to Business Configuration
- Go to Activity List
- Open the activity "Code List Mapping"
- Ensure that "BusinessPartnerRoleCode" is selected
- Maintain the relevant local and remote codes for the codes that are sent from external system
Solution when the roles are not supported in C4C
- The roles supported in C4C are "Account", "Competitor", "Contact", "Employee", "Prospect", "Channel_partner", "Store".
- These roles are by default blocked by replication programs in SAP CRM
- You can set filters in DRF to allows only these roles if you are replicating business partners from S4HANA
Keywords
BusinessPartnerReplicationIn, BusinessPartnerRoleCode , KBA , LOD-CRM-INT-CRM , Integration of C4C with CRM , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , Problem
Product
SAP Cloud for Customer core applications all versions